Cherokee installation error

When setting up a webserver on a Raspberry Pi v.2, running Raspian OS, you can choose Apache or go for something a little lighter. If you follow the instructions from the Raspberry Pi website you will encounter a Cherokee installation error.

I haven’t found anything that is light and will work on Raspian except Cherokee.

I encountered a Cherokee installation error and I had a few other issues installing it. If you read the documentation on Raspberrypi.org you will find some “solutions” that just don’t work.

If you follow the instructions there, you will end up (at some point) getting this Cherokee installation error:

[email protected] ~ $ sudo apt-get install cherokee
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package cherokee is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package ‘cherokee’ has no installation candidate

How to fix the Cherokee installation error

The only way I found out how to do it is as follows, get “autoconf”, “automake” and “libtool”:

sudo apt-get install autoconf automake libtool

Get “git”:

sudo apt-get install git

Check out Cherokee from Github:

git clone –recursive http://github.com/cherokee/webserver.git

The change directory to the webserver directory you just downloaded:

cd webserver

Run this script

./autogen.sh [options]

If it tells you there is no file or directory (/usr/bin/env: python2: No such file or directory)

sudo ln -s /usr/bin/python2.7 /usr/bin/python2

Then run the autogen.sh script again. Then run “make” and “make install”.

Let me know how it goes.

One Reply to “Cherokee installation error”

Leave a Reply

Your email address will not be published. Required fields are marked *